XCode 7を入れたらnode-gypが動かなくなった件

npmを実行すると以下のエラーを得る:

ld: library not found for -lgcc_s.10.5
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make: *** [Release/.node] Error 1

gccなのでXCodeが関連している模様。
関連情報:

I got the same error here, a possible error after upgrading xcode version.
I fix it with a temp solution:
cd /usr/local/lib sudo ln -s ../../lib/libSystem.B.dylib libgcc_s.10.5.dylib

とりあえず以下で対処できるらしい:

cd /usr/local/lib;
sudo ln -s ../../lib/libSystem.B.dylib libgcc_s.10.5.dylib 

んーむ・・

投稿者:

Takuya

Digital crafts(man|dog). Love photography. Always making otherwise sleeping. born in 1984.

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中